Archives

Everything Changed, No-one Noticed

Heh… got to amuse myself with this a little. Did anyone even notice that nodecaf.net moved today? Yes, indeed.

Basically, it was becoming impractical for me to keep running the server out of my house. I’m planning a vacation to the UK in a month, so for the duration of the trip this whole site was going to be shut down. That meant my friends sites, and my email. Of course, as history has now demonstrated I didn’t want to do this. Plus the fact that I get free Internet access through work, and the DSL is just an additional unnecessary expense at this time.

So, I made a deal with a company in town to host a server for me. Nothing stunningly powerful; a rather nice little HP Proliant DL360 G2. Old now, but a dual 1.4Ghz PIII (similar power to the server nodecaf.net used to be on), 1.2Gb of RAM and a pair of 36Gb SCSI drives in a RAID 1 config. Nothing spectacular, but a nice little piece of hardware.

For the sake of hardware management, though I put Windows on it. Fear not; it’s a copy of Windows 2003 I happen to own. A freebie that was given away at a trade show a couple of years ago. Anyway, no I did not abandon Linux for Windows; I simply made this choice because of the fact that I could not for the life of me get the hardware management stuff to work on anything other than Redhat Enterprise… at least out of the Linux distributions I’m familiar with. Of course, I’m not about to go out and buy RHEL… even CentOS (which is binary compatible with RHEL) wouldn’t work.

Besides, sometimes it’s nice to have a Windows box available if I need it. So I slapped on VMWare Server, set aside 24Gb of the storage to the VM and installed Gentoo. Ahhhhhhh…..

The better advantage of this was that I could take the config from the old server via RSYNC and stick it directly on the hardware with no modification. Voila; one new server hosting the site and everything works.

Well, OK… not everything worked at first. Initially I had some issues with PHP that I resolved quickly, then there were some firewall configurations I had to set up to make all the ports accessible. This morning after a day of churning data across the Internet, the new server had everything it needed (and had compiled all the packages it needed), and I turned everything on. A few test hits on the web site and a few test emails generated through TELNET and I was able to say everything was working as anticipated. Then it was just a matter of a DNS change, shut down mail services on the old server and cross my fingers.

It all went great. Within 15 minutes, I could see emails flowing to the new server and people hitting the web site. This server’s busier than you might think. As you can also tell, my blog is working.

So I moved my server 30 miles, with no perceptible downtime or loss of email. Not bad if I do say so myself 🙂

As it stands, the old server will be running for a few more days, catching the straggling DNS caches that insist on keeping DNS stuff in memory for days at a time but then I can safely shut off that web server. Not to mention, turn the sync around so I can pull data back from this new server to my old one… which will become just a home fileserver and my Linux workstation at home.

Sorry to anyone who found the performance a little lacking yesterday. Data was being pulled across the wire from my old server, and though it was throttled I was deliberately using about half my available bandwidth just so I could get it done. The new server’s been up for a few days and seems rock solid.

Any problems… please let me know!!!

Anyway, more on life, and the car… coming soon.

I’d post photos… but I’m having too much fun driving it 😉

2 Replies to “Everything Changed, No-one Noticed”

  1. ange says:

    So you’ve had over a month, where are the pics of the new ride? 😆

  2. gavin says:

    Hey, I’m too busy driving it to take pictures… or post… 😆

Leave a Reply

Your email address will not be published.